Monday, February 1 2010

WoW performance on the S12/ION

Fledge asked about the gaming performance on my ION-equipped Lenovo S12. At the time, the only benchmark I had was that it was possible to ride an epic mount around in Dalaran one evening at about 6 frames/second, but there’s really nothing you can do to get decent performance in Dal, on any machine; WoW just can’t handle a big crowd of people.

So, a more realistic test. Last night, I created a brand new level 1 human warlock named Lenova and ran her up to level 7. My framerate never dropped below 18 fps in the starter area, and averaged 24 fps there and in Elwynn Forest. It dipped to 14 briefly when I went into Goldshire (duels and a crowd), averaged 40+ in the mines, hit 12 in the main square of Stormwind (big crowd), but stayed a steady 15 outside the bank in Ironforge (moderate crowd). I even watched the character-intro movie, and it only had a few moments of choppy framerates; for the most part it was quite smooth, as was the gryphon flight back from Ironforge to Stormwind.

I had the visual effects settings pretty low, obviously, but this was at a full 1280x800, with the music and ambient sound on.

[Unrelated to gaming, but I like the fact that Win7 on the S12 is automatically switching to hibernate after the machine has been asleep for a few hours, and correctly resuming.]

[Update: we just tried the Star Trek Online headstart, and just flying around in space, we could get 10+ fps; once we entered a space station (which had a rapper as background “music”; word to my Federation homies, blech), it dropped to 5-6 fps, and lowering the resolution didn’t help much. The Atom just doesn’t have the guts, even assisted by an ION.]